aur_gitea-tea/PKGBUILD

27 rader
597 B
Bash

# Maintainer: John K. Luebs <jkl at johnluebs dot tld>
pkgname=gitea-tea
_pkgname=tea
pkgver=0.4.0
pkgrel=1
pkgdesc="Painless self-hosted Git service.."
arch=(x86_64)
url="https://gitea.io"
license=(MIT)
makedepends=(go-pie)
source=("https://gitea.com/gitea/tea/archive/v${pkgver}.tar.gz")
sha256sums=('689b67fac6200846633c66aa0a687371b20aa85a5d2d338a4e8f5f51b44d1b32')
build() {
cd ${_pkgname}
export TEA_VERSION=v${pkgver}
make
}
package() {
cd ${_pkgname}
install -Dm755 ${_pkgname} -t "${pkgdir}"/usr/bin/
install -Dm755 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}/
}